Maximum Number of Dishes

Ramu has N dishes of different types arranged in a row: A1,A2,…,AN where Ai denotes the type of the ith dish. He wants to choose as many dishes as possible from the given list but while satisfying two conditions:

  • He can choose only one type of dish.
  • No two chosen dishes should be adjacent to each other.

Ramu wants to know which type of dish he should choose from, so that he can pick the maximum number of dishes.
Example:
Given N= 9 and A= [1,2,2,1,2,1,1,1,1]
For type 1, Ramu can choose at most four dishes. One of the ways to choose four dishes of type 1 is A1,A4, A7 and A9.
For type 2, Ramu can choose at most two dishes. One way is to choose A3 and A5.
So in this case, Ramu should go for type 1, in which he can pick more dishes.
INPUT FORMAT:
The first line contains T, the number of test cases. Then the test cases follow.
For each test case, the first line contains a single integer N.
The second line contains N integers A1,A2,…,AN.
OUTPUT FORMAT:
For each test case, print a single line containing one integer ― the type of the dish that Ramu should choose from. If there are multiple answers, print the smallest one.

CONSTRAINTS:
1 <= T <= 10^3
1 <= N <= 10^3
1 <= Ai <= 10^3
Sample Input:
3
5
1 2 2 1 2
6
1 1 1 1 1 1
8
1 2 2 2 3 4 2 1
Sample Output:
1
1
2
Solution in C    PYTHON
#include<stdio.h>
int main() {
    int t,n,items[20],result[10],max,itemType,i,j,k,c;
    scanf("%d",&t);
    for(i=0;i<t;i++){
        scanf("%d",&n);
        for(j=0;j<n;j++)
            scanf("%d",&items[j]);
        max = 0;
        itemType = items[0];
        for(j=0;j<n;j++){
            c = 1;
            for(k=j+1;k<n;k++){
                if(items[j]==items[k] && k!=j+1){
                    c++;
                    if(k<n-1 && items[k]==items[k+1])
                        k++;
                }
            }
            if(max<c){
                max = c;
                itemType = items[j];
            }
        }
        result[i] = itemType;
    }
    for(i=0;i<t;i++)
        printf("%d\n",result[i]);
    return 0;
}

Input:
3
5
1 2 2 1 2
6
1 1 1 1 1 1
8
1 2 2 2 3 4 2 1
Output:
1
1
2